Why can I suddenly not import/copy/paste images?

Hello all,

I have encountered a problem I've never seen before -- when I try to add an image, Mural just adds a blank shape (in the shape of the image). This happens with images I try to copy/paste or import from my computer. It also happens with Mural's icons and images added via the Unsplash link. What's up? How can I fix this?

Separately, Mural keeps having trouble updating the page when it auto-saves. I have other apps open that use the Internet and they are all fine.

I'm not a Mural newbie -- I've made probably six murals over the last several months. So I know how to do it. It's just not working.

Any insights into this? Thank you!

Renee Hopkins

Best Answers

  • christinearcns
    christinearcns Mural Team mod
    Answer βœ“

    Hi @ReneeH! I hope your day is going well! πŸ‘‹ I tried reproducing this on my end by copying & pasting/importing images from my computer, using the Unsplash integration in the mural, Unsplash via share link, and using the drag & drop option. Please see the videos I recorded when I tried reproducing the issue. Would it be possible for you to send us a video e showing the issue? This will help our team identify the issue and help us with our investigation. Thank you in advance! Also, just want to set your expectations properly, incase we are unable to reproduce or identify the issue based on the video you will be sending over, we might need to reach out to you via email so we can further troubleshoot. Would that be okay? We look forward to hearing from you! 😊

  • blopez
    blopez Mural Team mod
    Answer βœ“

    Hi there!

    Ben here again from Mural's Support!

    Thanks @MarkPenver for sharing your experience. As per my previous post in this thread, this usually is related to network or internet inconsistencies.

    @gusandrebyna @Maike @barbmartin71

    Have you checked my answer on the top of this thread and tried any of the suggested checks?

    If you have and still finding these issues, please contact us at support via [email protected] or let me know and I will be happy to contact you directly via email.

    Looking forward to hearing from you!



  • Hi there, just want to highlight that I'm having the same issue! It probably start about a month ago, and now it just randomly happened and it is very painful!

    Below is an image that I copied across and it became just a box. Another example is when I add an icon and move it around, it will disappear. There is a random spot on the frame where the icon will just disappear.

  • I am having the same problem. Nothin will copy and paste at the moment, either within or between murals.

  • minnie6
    edited October 2022

    Same for me when I drag & drop images or insert it through "images - from my computer". I feel like it happens randomly. Also, sometimes when I move the images, it suddenly disappears. Always have to undo the move so it would reappear. Has this issue been resolved ?

  • @muralmods any update for this issue? I have a meeting today with 30 participants and have planned an icebreaker activity that involves copy-pasting images off google. Currently, it's displaying a grey box in the place of the image. Any help in the next 2 hours will be helpful. @MuralMaster @christinearcns

  • Same issue here: when uploading any image (png, pdf), it's displaying a grey box in the place of the image. Strange enough, the first few seconds the image is shown – but then it disappears, being replaced by the grey box.

  • Same issue here, I see it then it disappears leaving the grey box. It's very random.

  • Same issue. It only happens with some images. On some I am able to drag them again and they appear, but with others ones, this doesn't work. Any update? Is it a bug? or something I need to change. Thanks,

  • I made a short screen share to reproduce the issue - suddenly not working for me either

    Do you have any solutions yet @MuralMasterΒ @christinearcns?


  • Also - I just logged into Mural with an Incognito window and it worked ok -so, it might be something to do with Cacheing...?


  • THIS ISSUE PERSISTS (and I don't see that anyone has suggested a solution).

    ISSUE: When I try to drag&drop or copy/paste or even Import Files an image into a Mural Board I am often (but not always- problem comes and goes) left with a grey box instead of the image. I DO NOT see a little circle in the top/right corner to suggest it is simply stuck in downloading.

    I have tested brining images in as PNG, PDF and other formats without any change in the problem.

    @MuralMaster @christinearcns (whom I am assuming are mural app staff, yes?) - any results on this? It is becoming a major problem as we cannot rely on Mural when we most need it before a presentation.

  • I am having the same issue - copy, Control + V was pasting just fine - then mid-project it stopped working and getting the same grey box with circles but no handles to scale - the image is visible for a second but then disappears and leaves a grey empty box.

    I tried to import from my computer and had the same result.

    Super frustrating. Pls advise.

  • Any update on how best to work around this bug?

  • I'm having the same issue, upload from computer, drag & drop...all present the image briefly which then changes to a grey box with an 'Upload Failed' error message. This is becoming frustrating but glad I'm not the only one. Mural, come on please. No response to these issues since April?

  • I've had this problem too, and every time, it is solved by the magical reboot of my computer!

  • I was experiencing the exact same problem - sometimes an image pasted in would resolve and other times, I would just get a grey box.

    I've been able to reliably address this seemingly random problem by opening the Images drawer from the left toolbar before I paste the image in. If the drawer is open and you "ctrl-v" the image shows on my Mural canvas.

    Hope this helps!

  • I am having this issue both when trying copy/paste and importing images from the computer in to the Mural. Has anyone gotten a response from Mural?

  • I have also been experiencing this issue.

  • Having a rough time with this same issue today. With some experimentation, I discovered that exporting a PNG (screenshot) then opening it with Preview (Mac) as a PDF, allowed me to import the image, though it was rotated. Sometimes when I moved the image it would turn into the grey box, but I could "undo" and then use arrow keys to move it around.

    The images panel tip didn't seem to matter, FWIW. I was able to drag a PDF copy of the PNG in place, and move it around; if I dragged on top of another element or area, that did seem to activate the grey box error.

    Super annoying. i can screen share if you like.

  • I am having the same issue. Sometimes when uploading screenshots onto a board they just appear grey - other times the images on the whole board will just appear grey.

    No amount of refreshing seems to help

    @MuralMaster any comments or suggestions?

  • flyingcars
    edited January 23

    Grrr - my team and I are also starting to have this issue since the beginning of Jan. Did anyone get any answers on this? the image appears for a millisecond when I upload and then it disappears, leaving just a blank grey box that cannot be resized. @MuralMaster any help would be appreciated. It doesn't happen all the time, only some of the time. But inevitably when it does happen might be just prior to a huge workshop or something I'm facilitating.

  • @MuralMasterΒ @christinearcns, I'm also experiencing the problem with Images rendering, it's not consistent and extremely frustrating, when you are relying on a Mural board for an important facilitation. Is anyone looking into this issue/are there workarounds?

  • @Darren

    jhaggarty's solution above worked for me just now. Open the image "drawer" in the left sidebar and then drag the image onto the mural from your computer or paste. Weirdly, it worked.

  • @MuralMaster been having the same issue for a while, it's very frustrating. Tried Upload and Drag n' Drop. Sometimes it works and sometimes it doesn't. If it's not resolved will be switching to another Tool.

  • Same. I've tried drag and drop and the upload option. Neither has worked. I've searched and I can't find a fix anywhere.

  • Having the same issue today, even with a brand new account. Windows or Mac, same issue... :-(

  • Not the same issue but similar, I'm no longer able to drag and drop in Screenshots. Creating a repository of screenshots we annotate and explore is my bread and butter. Please help.

  • I was about to post that I'm having the same issue, which I am, but it does appear that the toolbar option is working.

    That is, dragging and dropping my image onto the canvas produces that grey box. However, if I go to the toolbar, click on Images/Import Images/Your Computer, my Chrome Browser file explorer appears, I select the image and click Open, and the image successfully appears.

    Hope it can work for y'all as well!

  • I am experiencing the same problem, it's been a problem for some months now. I can not paste any images. I can not add them via toolbar neither. The image appears for 1 second once pasted and than converts into a grey box. @MuralMaster What to do?

  • Meghan
    Meghan ✭✭✭

    Hang in there, @Maike- help is on the way!

    cc: @gusandrebyna @MAS

  • I am having the same issue that people have been posting about since April 2022 - and it is now March 2023. What is the fix?! I see no solution from @MAS @MuralMaster. I have tried different browsers (Chrome, Safari). Images may stay for several seconds, but after a short time, they disappear. Then I tried importing a small (<1MG) image from my computer. Upload failed. 😫

    This could be a (bad) sketch for a comedy skit, except that it is having real-world implications. In 10 days I am running a 2-day strategic planning retreat ENTIRELY RUN ON MURAL for a large client - and panic is setting in. PLEASE fix this!

  • So.... I think I have it. I create a Mural and then was absent for a bit and came back and it struggled to import. I then struggled when I had switched networks. I went back to my home, tried to import the images onto a clean canvas and it worked. I then came back to my original canvas and it worked. I wonder if there's a reconnection / permissions issue.

  • So the advice being given here about connectivity is basically nonsense. I have the same problem, and it was clear that Mural was rendering the imported picture, then drawing a grey box over it. I tried saving images in different formats, and then importing them. Windows bitmap works properly every time.

    Mural has a software fault, and it would be good if they fixed that rather than blame peoples' network connections.

  • Christina
    Christina ✭✭✭✭

    This started happening to me here in Germany about a month ago too! Any image, either from my computer or anywhere else will randomly show for a moment then be replaced by a gray box. I am not in the IT department and it is not possible for us to always look into those technical issues and get an answer before a week or so goes by, which makes using Mural very nerve-wracking at the moment as I never know if it will work or not. Images are a key part of the many murals I work with. It will work on one but not on another a moment later. It only very rarely happened before, plus our connectivity is always about the same for everything else, so I do wonder if it isn't something inside Mural as nothing else is affected. This is a very important phenomenon/glitch. I hope there is a solution soon.

    edited May 8

    Happening to me as well. I've had multiple times where uploading an image results in the gray image. Deleting and redoing it was working earlier, but now it seems to happen quite a bit. The workaround that seems to work is to leave the Mural, go the dashboard and reload the Mural and then past the picture. So far, that's working for me…

  • Meghan
    Meghan ✭✭✭

    Hi Everyone! @JDHTX @Christina @paul_r @MarkPenver @barbmartin71

    I've spoken with Support on this one, and there isn't a strong overlap to what is happening just yet or how to solve in a one-size approach. Could you share what is happening to [email protected]? This way, there is stronger documentation of what is occurring. thanks for keeping us updated here!

  • Christina
    Christina ✭✭✭✭

    Hi @Meghan! Thank you for looking into this, I really appreciate it. I will contact support the next time it happens.

    Another idea: I notice a lot of people create a gif to show things, but I don't know how to do that and notice Mural often asks for one to see what's happening. Perhaps one idea would be to have a short "Making a Gif for Idiots" πŸ˜… video somewhere in the Community that we can watch when we want to create one to show others - not only when there is a problem. This is also a cool thing to be able to do within a Mural for other reasons while collaborating and perhaps I am not the only one who doesn't know how to do it. Thanks again!

  • Meghan
    Meghan ✭✭✭

    I like this idea, @Christina! This is something I've done for a while now, but short answer: there are many apps you can use to do it! I'm using a Mac, so I use a combo of iMovie + Giphy. I'll look at a non-Mac option as well and see if I can share a post to help. 😊

  • Christina
    Christina ✭✭✭✭

    Hi @Meghan thank you, I have a Windows device so any suggestions would be great on gif making on my laptop. However, I just had another example that I simply copy paste here: one image from my computer, the notes in the background, came up just fine. The next one did not and gave this Upload failed message. Mystifying!

  • Meghan
    Meghan ✭✭✭

    That's definitely odd, @Christina! Definitely pass this to support with added info that you're testing from Windows. πŸ˜•

    I'll test gif making options from my personal laptop, which is also a windows computer! Will keep you posted.

  • indreko
    indreko ✭

    It actually helped me to restart my mac.

  • pdmoore
    pdmoore ✭
    edited October 6

    Still experiencing this problem. I am trying to use the supplied Icon for the Magic 8-ball, and it always shows up as gray. Tried a lot of the above suggestions with no luck.

    Then I tried picking icons at random - about half show up as gray while the others show up as expected. Can't justify how time I am wasting on this.

    Selecting icons from the icons selection, from the top of the listing.

    First row: Circled Right Arrow does not work; Check Mark and Circled X work.

    Second row: only the middle Circled Question Mark works. The other two appear as gray boxes.

    Tried this on Windows/Chrome, Mac/Chrome, Mac/Safari