Cannot import from Jira

I had a working Jira-Mural integration. On Friday it seemed to stop working.

I have asked our local Jira admin to check, but he says that the integration is still enabled from his side.

I tried removing and re-enabling the integration from Mural's side, but still no change.

You can see in the first screenshot that I have the option, and can send stickies to Jira.

But you can see in the next screenshot that I have no option to import issues from Jira.

Has something changed, am I doing something wrong or is there something else that I need my Jira admin to check on our cloud instance?


  • Same issue!
    We're planning a 200+ person event next week relying on this feature. We're using this since more than one year without any issue.

    Any chance to fix this import quickly?

  • Glad I'm not the only one @Greg_b! Need more people to suffer with me…

    I am chatting with Support over email. Hopefully I have a resolution soon that will benefit everyone.

  • @munkychunks Thanks a lot!
    I will stay tuned for any progress on this!

  • munkychunks
    edited September 19

    It may be too late for your event @Greg_b but I see that this working again. I had no more help from support, but they obviously fixed something.

    Hope it comes right for you too…